Reported issues with ID verification
Incident Report for Stavvy Status Page
Resolved
Our engineers were able to track down what was causing this issue and have resolved it.
Posted Jan 14, 2023 - 02:25 UTC
Investigating
Customers are experiencing issues with ID verification that may be a result of our 3rd part vendor having an outage. Our team is currently investigating this issue.
Posted Jan 14, 2023 - 00:39 UTC
This incident affected: Stavvy Remote Meetings, eSignatures, and Notarization (Remote Meetings).