Video recording download issue
Incident Report for Stavvy Status Page
Resolved
This incident has been resolved. Video recordings and the downloading of video recordings is working as expected.
Posted Apr 28, 2022 - 21:30 UTC
Investigating
Customers have reported issues downloading video recordings. Our engineers are currently investigating this issue.
Posted Apr 28, 2022 - 20:42 UTC
This incident affected: Stavvy Remote Meetings, eSignatures, and Notarization (Recording requests).