System Performance Downgraded

Incident Report for Stavvy Status

Resolved

We have resolved the the issue. Thank you for your patience.
Posted Sep 23, 2026 - 04:15 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 22, 2026 - 14:19 UTC

Update

System performance is improving, but we will continue to monitor it throughout the day.
Posted Sep 22, 2026 - 14:19 UTC

Investigating

We are aware of the issues being experienced in the platform this morning. Our engineering team is currently investigating.
Posted Sep 22, 2026 - 13:12 UTC
This incident affected: Stavvy Remote Meetings, eSignatures, and Notarization (Document eSigning, Remote Meetings, Notary Profile and Configuration, Real-time Audio and Visual Communication, In-meeting recording, Recording requests, Text Messages, ID and KBA Verification).