[02/25/2022] Update: Bug investigation
Incident Report for Stavvy Status Page
Resolved
This incident has been resolved.
Posted Feb 25, 2022 - 21:27 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 25, 2022 - 17:50 UTC
Investigating
We are currently investigating an issue where some users are unable to tag documents successfully for signing. We will share an update once we have more information.
Posted Feb 25, 2022 - 17:18 UTC
This incident affected: Stavvy Remote Meetings, eSignatures, and Notarization (Document eSigning).