IP Verification Service is currently down and affecting user's ability to join Meetings

Incident Report for Stavvy Status

Resolved

This incident has been resolved.
Posted Sep 29, 2025 - 17:49 UTC

Update

We are continuing to work on a fix for this issue.
Posted Sep 29, 2025 - 17:16 UTC

Identified

The issue has been identified but there isn't an ETA on resolution at this time.
Posted Sep 29, 2025 - 16:33 UTC
This incident affected: Stavvy Remote Meetings, eSignatures, and Notarization (Remote Meetings).