Degraded performance across Stavvy platform

Incident Report for Stavvy Status Page

Resolved

We were able to identify and resolve issues on our backend. All services are running as intended.
Posted Mar 23, 2022 - 21:57 UTC

Investigating

Degraded performance reported across Stavvy eSign environments
Posted Mar 23, 2022 - 20:57 UTC
This incident affected: Stavvy Remote Meetings, eSignatures, and Notarization (Document eSigning).