ID verification issue (Credential Analysis)
Incident Report for Stavvy Status Page
Resolved
This incident has been resolved.
Posted Apr 18, 2024 - 17:21 UTC
Identified
Customers are reporting issues with ID verification when uploading images of their ID. We have identified the issue and are working with our vendor to resolve this.
Posted Mar 13, 2024 - 21:52 UTC
This incident affected: Stavvy Remote Meetings, eSignatures, and Notarization (Remote Meetings).