ID Verification Issues
Incident Report for Stavvy Status Page
Resolved
This incident has been resolved.
Posted Sep 28, 2022 - 00:24 UTC
Monitoring
Engineers have implemented a fix to resolve this issue. We are currently monitoring to make sure everything is work as intended.
Posted Sep 27, 2022 - 22:41 UTC
Identified
We have identified the issue with the ID verification link not being sent to the customer. Our third-party vendor Twilio is currently experiencing issues impacting T-mobile customers https://status.twilio.com/. We are currently working with our vendor to relay updates on a fix for impacted customers.
Posted Sep 22, 2022 - 17:56 UTC
Update
We are continuing to investigate this issue.
Posted Sep 19, 2022 - 15:10 UTC
Investigating
We are experiencing some issues where signers are not receiving text messages during ID verification. We are currently investigating and will update our status when more information is discovered.
Posted Sep 19, 2022 - 15:10 UTC