Degraded performance with Stavvy eSign
Incident Report for Stavvy Status Page

Resolved
All performance issues have been resolved and documents will now finalize without issue.
Posted Apr 01, 2022 - 00:35 UTC
Monitoring
A fix has been implemented and we are currently monitoring.
Posted Mar 31, 2022 - 23:04 UTC
Identified
The issues with the degraded performance in Stavvy eSign have been identified and our engineering team is working on resolving this.
Posted Mar 31, 2022 - 16:30 UTC
Investigating
There have been reports of degraded performance when finalizing multiple documents in Stavvy eSign. Our engineers are investigating this issue.
Posted Mar 31, 2022 - 13:31 UTC
This incident affected: Stavvy Remote Meetings, eSignatures, and Notarization (Document eSigning).