ID Verification Text Links - Sporadic Direct Failure

Incident Report for Stavvy Status

Resolved

This incident has been resolved.
Posted Aug 15, 2025 - 19:44 UTC

Identified

The third-party vendor is experiencing sporadic link redirect failures, and they are actively working to resolve them. This is affecting the signer's ability to open the ID verification text link.

From the third-party vendor Status Page:

Identified - We've identified that the issue is primarily affecting customers using AT&T network connections. Our team is now in contact with AT&T to resolve the network connectivity issue. Larger ISPs (T-Mobile, Xfinity, etc.) are unaffected, but smaller ISPs may run into similar issues.
Aug 13, 2025 - 14:04 UTC

Investigating - We're actively investigating reports of intermittent link redirect failures. Initial testing shows all links redirecting correctly from multiple locations and VPNs. Service monitoring indicates normal operation with no interruptions detected. Click tracking data remains consistent with August averages.
Aug 12, 2025 - 16:28 UTC
Posted Aug 14, 2025 - 13:58 UTC