Unable to edit annotations when document status = "Signing in Progress"
Incident Report for Stavvy Status Page
Resolved
This incident has been resolved.
Posted May 01, 2024 - 22:49 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 01, 2024 - 22:20 UTC
Identified
We have identified the root cause and we're working on the permanent solution.

Until this has been resolved, if you run into this issue, please reach out to support@stavvy.com and the support team can assist.
Posted May 01, 2024 - 18:55 UTC
This incident affected: Stavvy Remote Meetings, eSignatures, and Notarization (Remote Meetings).