Cloud Provider (AWS) Global Outage

Incident Report for Stavvy Status

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 12:46 UTC

Update

The AWS outage has been resolved and all relevant services in Stavvy are operational.
Posted Oct 20, 2025 - 22:43 UTC

Monitoring

The AWS global outage continues to cause intermittent issues with various services in Stavvy. The ID verification has recovered.
Posted Oct 20, 2025 - 21:25 UTC

Update

The AWS global outage continues to cause intermittent issues with various services in Stavvy. The ID verification portion of the verification process is not available. The KBA section is still functional at this time.
Posted Oct 20, 2025 - 19:33 UTC

Update

The AWS global outage continues to cause intermittent issues with various services in Stavvy. The ID verification portion of the verification process is not available. The KBA section is still functional at this time.
Posted Oct 20, 2025 - 19:31 UTC

Update

Services appear to be recovering, text messages are being sent and received, and meetings are being joined and finalized.
Posted Oct 20, 2025 - 16:19 UTC

Identified

We understand the impact this issue is having on your operations and want to assure you that resolving this matter is our highest priority. Our cloud provider is actively working to mitigate this issue with urgency. While we do not have a definitive ETA at this time, we remain committed to full resolution and deeply appreciate your patience as we work through this situation.
Posted Oct 20, 2025 - 15:41 UTC
This incident affected: Stavvy Remote Meetings, eSignatures, and Notarization (Remote Meetings, Real-time Audio and Visual Communication, In-meeting recording, Recording requests, Text Messages, ID and KBA Verification).