Reported issue with document finalization
Incident Report for Stavvy Status Page
Resolved
This issue has been identified and resolved.
Posted Apr 23, 2022 - 00:43 UTC
Investigating
Customers have reported an issue with document finalization. Our engineering team is currently diagnosing this issue.
Posted Apr 22, 2022 - 21:36 UTC
This incident affected: Stavvy Remote Meetings, eSignatures, and Notarization (Remote Meetings).